Phone System Operational
Incident Report for Elite Payroll Solutions
Postmortem

Phone vendor experienced a controller issue yesterday evening. Fix was completed this morning.

Posted Dec 08, 2022 - 10:38 EST

Resolved
Our phone system is now completely operational. We will continue to monitor for reliability throughout the day.
Posted Dec 08, 2022 - 09:40 EST
Monitoring
A fix for the phone system has been applied and we are monitoring the results closely.
Posted Dec 08, 2022 - 09:18 EST
Investigating
We are currently investigating an issue related to our phone system not being able to make or receive phone calls. A case has been opened with our vendor.
Posted Dec 08, 2022 - 08:55 EST
This incident affected: Communications (Office Phones).