PrismHR Support Alert --- Document Management is Temporarily Unavailable
Incident Report for Elite Payroll Solutions
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 08:13 EDT
Investigating
Our vendor has indicated to our team that the "Document Management" service, within the PrismHR Payroll Portal, is temporarily unavailable. Unscheduled maintenance is being carried out to correct the error. This will also affect "My Documents" in the Employee Portal.

Upon attempting to access Document Management, users will get an Error 403 blue screen while the service is unavailable.

This is also affecting document sets and onboarding activities.

We will update you as soon as we are aware of any changes.
Posted Mar 29, 2022 - 16:56 EDT
This incident affected: Payroll (Employee Portal, Manager Portal).