Certificate Error when accessing PrismHR through Chrome browser
Incident Report for Elite Payroll Solutions
Resolved
The issue has been resolved. We are no longer seeing the certification error on PrismHR URLs. Please note: it is possible that Chrome will have cached the certificate in an open browser session, if you or your team do experience this please close out of Chome fully and try again.
Posted May 03, 2022 - 08:10 EDT
Investigating
Good afternoon,

We have been alerted by our vendor that there may be some issues encountered when attempting to access the PrismHR Platform, from Google Chrome, due to a Certificate Error.

If you encounter this Certificate Error, please try to use an alternate web browser (Microsoft Edge or Mozilla Firefox have been confirmed to work) as an alternative, while they investigate the issue further.

We will update you with further information as it becomes available to us.
Posted May 02, 2022 - 15:53 EDT
This incident affected: Payroll (Employee Portal, Manager Portal).