Employee Portal Currently Unavailable
Incident Report for Elite Payroll Solutions
Resolved
This incident has been resolved.
Posted Dec 16, 2022 - 11:05 EST
Monitoring
Employee Portal functionality has been restored. Our vendor is closely monitoring the situation for any further problems.
Posted Dec 16, 2022 - 09:45 EST
Identified
The Employee Portal is currently unavailable to all environments. Our vendor's Engineering and Operations resources are aware and are working on restoring access. We do not have an ETA of services at this time, but will continue to provide updates as functionality is restored.
Posted Dec 16, 2022 - 08:53 EST
This incident affected: Payroll (Employee Portal).