Office phone system is temporarily down
Incident Report for Elite Payroll Solutions
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 16:46 EDT
Monitoring
A temporary fix has been implemented, you should now be able to reach us by phone again. We will keep you updated if anything changes.

Thank you,
Support
Posted Apr 11, 2022 - 12:56 EDT
Investigating
We apologize for the inconvenience, however, our office phone lines are currently down, as we are experiencing issues with our internet provider. We are currently investigating this issue and will provide more information as it becomes available to us. The best form of communication currently will be via email.

Thank you,
Support
Posted Apr 11, 2022 - 10:16 EDT
This incident affected: Communications (Office Phones).